Down alert: Correos Express is DOWN
Incident Report for Deliverea
Resolved
Alert UP: Correos Express is UP again at 11/26/2021 01:18:44 PM, after 17m of downtime.
Posted Nov 26, 2021 - 13:20 CET
Monitoring
DOWN alert: Correos Express is down since 11/26/2021 01:01:44 PM.
Posted Nov 26, 2021 - 13:08 CET
This incident affected: Carriers (Correos Express).